compat53

Compatibility module providing Lua-5.3-style APIs for Lua 5.2 and 5.1

$ luarocks install compat53

This is a small module that aims to make it easier to write Lua code in a Lua-5.3-style that runs on Lua 5.3, 5.2, and 5.1. It does *not* make Lua 5.2 (or even 5.1) entirely compatible with Lua 5.3, but it brings the API closer to that of Lua 5.3.

Versions

scm-0dev185 days ago4,686 downloads
0.13-157 days ago23,981 downloads
0.12-1170 days ago49,063 downloads
0.11-1185 days ago8,457 downloads
0.8-1185 days ago662,074 downloads
0.7-1185 days ago146,747 downloads
0.5-1185 days ago5,108 downloads
0.4-1185 days ago478 downloads
0.3-1185 days ago8,716 downloads
0.2-1185 days ago124 downloads
0.1-1185 days ago407 downloads

Dependency for

croissant, expadom, hectorm-fork-http, hotswap, http, Light, lsdbus, lsp-lib, LuaText, lua-zabbix-sender, lwtk, meta, mmdblua, sile, sirocco, tabular, teal-cli, tl, tulip, ufy

Manifests