compat53

Compatibility module providing Lua-5.3-style APIs for Lua 5.2 and 5.1

$ luarocks install compat53

This is a small module that aims to make it easier to write Lua
code in a Lua-5.3-style that runs on Lua 5.3, 5.2, and 5.1.
It does *not* make Lua 5.2 (or even 5.1) entirely compatible
with Lua 5.3, but it brings the API closer to that of Lua 5.3.

Versions

scm-0dev2 years ago(revision: 2)3,004 downloads
0.8-12 years ago311,327 downloads
0.7-14 years ago146,209 downloads
0.5-15 years ago4,958 downloads
0.4-15 years ago453 downloads
0.3-17 years ago8,674 downloads
0.2-17 years ago99 downloads
0.1-17 years ago149 downloads

Dependencies

lua >= 5.1, < 5.5

Dependency for

croissant, expadom, hectorm-fork-http, hotswap, http, lsdbus, lua-zabbix-sender, lwtk, mmdblua, sirocco, tabular, teal-cli, tl, tulip, ufy

Manifests