lua-periphery

Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) with Lua

$ luarocks install lua-periphery

lua-periphery is a library for GPIO, LED, PWM, SPI, I2C, MMIO, and Serial peripheral I/O interface access in userspace Linux. It is useful in embedded Linux environments (including Raspberry Pi, BeagleBone, etc. platforms) for interfacing with external peripherals. lua-periphery requires Lua 5.1 or greater, has no dependencies outside the standard C library and Linux, is portable across architectures, and is MIT licensed.

Versions

2.4.2-1281 days ago701 downloads
2.4.1-1357 days ago380 downloads
2.4.0-11 year ago196 downloads
2.3.1-13 years ago2,923 downloads
2.3.0-13 years ago143 downloads
2.2.5-13 years ago102 downloads
2.2.4-13 years ago193 downloads
2.2.2-13 years ago161 downloads
2.2.1-13 years ago109 downloads
2.2.0-13 years ago43 downloads
2.1.0-14 years ago315 downloads
2.0.1-14 years ago241 downloads
1.1.3-15 years ago2,179 downloads
1.1.2-16 years ago57 downloads
1.1.1-16 years ago6,606 downloads
1.1.0-17 years ago188 downloads
1.0.6-18 years ago6,647 downloads
1.0.5-28 years ago294 downloads
1.0.5-18 years ago53 downloads
1.0.4-19 years ago367 downloads
1.0.3-19 years ago67 downloads
1.0.2-19 years ago181 downloads
1.0.1-19 years ago154 downloads
1.0.0-19 years ago65 downloads

Dependencies

lua >= 5.1

Dependency for

ads1015, adxl345, bme280, ht16k33, sgp30

Labels

Manifests