Compatibility module providing Lua-5.3-style APIs for Lua 5.2 and 5.1

$ luarocks install compat53

This is a small module that aims to make it easier to write Lua
code in a Lua-5.3-style that runs on Lua 5.3, 5.2, and 5.1.
It does *not* make Lua 5.2 (or even 5.1) entirely compatible
with Lua 5.3, but it brings the API closer to that of Lua 5.3.


scm-0dev3 years ago(revision: 2)4,255 downloads
0.8-13 years ago644,897 downloads
0.7-15 years ago146,598 downloads
0.5-16 years ago5,077 downloads
0.4-16 years ago468 downloads
0.3-18 years ago8,704 downloads
0.2-18 years ago114 downloads
0.1-18 years ago397 downloads


lua >= 5.1, < 5.5

Dependency for

croissant, expadom, hectorm-fork-http, hotswap, http, lsdbus, lua-zabbix-sender, lwtk, mmdblua, sile, sirocco, tabular, teal-cli, tl, tulip, ufy