luacheck

A simple static analyzer

$ luarocks install luacheck

luacheck only looks for three things: non-standard global variables, unused local variables and redefinitions of existing local variables in the same scope.

luacheck provides a command-line interface as well as a small library which can be used from another Lua program.

Versions

0.24.0-2347 days ago443,812 downloads
0.24.0-1347 days ago11 downloads
0.23.0-1347 days ago716,741 downloads
0.22.1-1347 days ago41,073 downloads
0.22.0-1347 days ago29,623 downloads
0.21.2-1347 days ago212,156 downloads
0.21.1-1347 days ago77,833 downloads
0.21.0-1347 days ago2,549 downloads
0.20.0-1347 days ago246,093 downloads
0.19.1-1347 days ago20,528 downloads
0.19.0-1347 days ago2,597 downloads
0.18.0-1347 days ago17,477 downloads
0.17.1-1347 days ago8,206 downloads
0.17.0-1347 days ago15,528 downloads
0.16.3-1347 days ago43,701 downloads
0.16.2-1347 days ago4,314 downloads
0.16.1-1347 days ago9,474 downloads
0.16.0-1347 days ago206 downloads
0.15.1-1347 days ago32,517 downloads
0.15.0-1347 days ago11,847 downloads
0.14.0-1347 days ago11,707 downloads
0.13.0-1347 days ago7,959 downloads
0.12.0-1347 days ago3,171 downloads
0.11.1-1347 days ago4,638 downloads
0.11.0-1347 days ago840 downloads
0.10.0-1347 days ago2,672 downloads
0.9.0-1347 days ago267 downloads
0.8.0-1347 days ago12,388 downloads
0.7.3-1347 days ago12,376 downloads
0.7.2-1347 days ago73 downloads
0.7.1-1347 days ago114 downloads
0.7.0-1347 days ago69 downloads
0.6.0-1347 days ago195 downloads
0.5.0-1347 days ago167 downloads
0.4.1-1347 days ago50 downloads
0.4.0-1347 days ago81 downloads
0.3.0-17 years ago29 downloads
0.2.0-17 years ago34 downloads
0.1.0-17 years ago20 downloads

Dependencies

ansicolors >= 1.0-1
argparse >= 0.2.0
checks >= 1.0
lua >= 5.1, < 5.3
metalua-parser >= 0.7.3-2

Dependency for

candran, coronastd, lua-complete, mocka, petrisport

Labels

Manifests