Minimal API for building GUIs

$ luarocks install lpugl

LPugl is a minimal portable Lua-API for building GUIs.
Currently there are two drawing backends available,
see packages "lpugl_cairo" and "lpugl_opengl".
Supported platforms: X11, Windows and Mac OS X.
LPugl is based on Pugl, a minimal portable API for embeddable GUIs,
see: https://drobilla.net/software/pugl

Versions

scm-0dev1 year ago(revision: 5)355 downloads
0.0.3-1140 days ago83 downloads
0.0.2-11 year ago155 downloads
0.0.1-11 year ago(revision: 2)12 downloads

Dependencies

lua >= 5.1, <= 5.4

Dependency for

lpugl_cairo, lpugl_opengl

Labels

Manifests