lua-llthreads2-compat

Low-Level threads for Lua

$ luarocks install lua-llthreads2-compat

This is drop-in replacement for `lua-llthread` module.
In additional module supports: thread join with zero timeout; logging thread errors with
custom logger; run detached joinable threads; pass cfunctions as argument to child thread.

Versions

scm-0dev1 year ago(revision: 2)158 downloads
0.1.6-11 year ago56 downloads
0.1.5-14 years ago136 downloads
0.1.4-16 years ago208 downloads
0.1.3-17 years ago104 downloads
0.1.2-18 years ago40 downloads
0.1.1-18 years ago49 downloads
0.1.0-18 years ago58 downloads

Dependencies

lua >= 5.1, < 5.5

Labels

Manifests