org.conman.parsers.utf8

LPEG expression to match valid ISO characters

$ luarocks install org.conman.parsers.utf8

LPEG expression to match valid UTF-8 characters, both graphic and
control sets. This module handles *only* the characters not defined
by ASCII. If you need to parse both ASCII and UTF-8:

char = require "org.conman.parsers.utf8"
+ require "org.conman.parsers.ascii"

NOTE: The UTF-8 control characters may match more than a single
character. For example, the commonly called ANSI codes (which are
not ANSI but ISO) like "<ESC>[32;40m" will be matched as one unit.

Versions

1.0.0-2224 days ago11 downloads
1.0.0-11 year ago15 downloads

Dependencies

LPeg >= 1.0.0
lua >= 5.1, <= 5.4

Manifests