luajls-lfs

luajls with dependencies luafilesystem and luasocket

$ luarocks install luajls-lfs

luajls aims to be a standard library for stand-alone Lua applications
The library provides an abstract interface to the underlying operating system, such as file system and network access.
The jls Lua library is composed of a set of jls Lua modules. The jls Lua library also provides interface for general purpose libraries such as JSON, ZIP, SSL. The main targeted OSes are Linux and Windows.
Prerequisites on Linux:
sudo apt install luarocks lua5.3 lua5.3-dev libz-dev

Versions

0.2-1220 days ago(revision: 2)13 downloads

Dependencies

lua >= 5.3, < 5.4

Manifests