luassert

Lua Assertions Extension

Adds a framework that allows registering new assertions
without compromising builtin assertion functionality.

Versions

1.8.0-04 years ago1,567,961 downloads
1.7.11-05 years ago165,544 downloads
1.7.10-07 years ago566,220 downloads
1.7.9-08 years ago78,494 downloads
1.7.8-08 years ago2,230 downloads
1.7.7-08 years ago761 downloads
1.7.6-08 years ago2,356 downloads
1.7.5-08 years ago1,497 downloads
1.7.4-09 years ago1,534 downloads
1.7.3-09 years ago887 downloads
1.7.2-09 years ago613 downloads
1.7.1-09 years ago1,996 downloads
1.7.0-19 years ago28,250 downloads
1.7.0-09 years ago110 downloads
1.6-19 years ago253 downloads
1.5-19 years ago125 downloads
1.4-19 years ago91 downloads
1.2-19 years ago95 downloads
1.0-19 years ago114 downloads

Dependencies

lua >= 5.1
say >= 1.2-1

Dependency for

busted, busted, busted, busted, busted-ffi, busted_resty, bustest, bustez, expect-spy, fffonion-busted, LuaBehave, luatest, muck, plenary.nvim, plenary.nvim, validate-args

Labels