compat53

Compatibility module providing Lua-5.3-style APIs for Lua 5.2 and 5.1

$ luarocks install compat53

This is a small module that aims to make it easier to write Lua
code in a Lua-5.3-style that runs on Lua 5.3, 5.2, and 5.1.
It does *not* make Lua 5.2 (or even 5.1) entirely compatible
with Lua 5.3, but it brings the API closer to that of Lua 5.3.

Versions

scm-0dev4 years ago1,776 downloads
0.7-1343 days ago42,947 downloads
0.5-11 year ago4,521 downloads
0.4-11 year ago441 downloads
0.3-13 years ago8,654 downloads
0.2-14 years ago87 downloads
0.1-14 years ago57 downloads

Dependencies

lua >= 5.1, < 5.4

Dependency for

croissant, hotswap, http, ip-reputation, mmdblua, sirocco, ufy

Manifests